Archive for Операционные системы

Debian (Ubuntu) обновление просроченных ключей apt

// Апрель 23rd, 2018 // No Comments » // apt, Debian, linux

Решил я доставить софта на древний Debian, а в ответ поулчил вот такое:

W: Ошибка GPG: http://archive.debian.org squeeze Release: Следующие подписи неверные: KEYEXPIRED 1520281423 KEYEXPIRED 1501892461

естественно apt отказывает устанавливать что-то, если нет доверия репозиторию, что бы это вылечить — нужно обновить просроченные ключи, для этого, нужно их найти:

apt-key list

на выходе обнаруживаем строки типа:

pub   1024D/F42584E6 2008-04-06 [просрочен с: 2012-05-15]
uid                  Lenny Stable Release Key <debian-release@lists.debian.org>

и таких ключей может быть несколько, что бы быстро их найти:

apt-key list | grep "[expired|просрочен]"

Теперь нужно обновить ключи, для этого нужно запустить команду с указанием идентификатором ключа:

apt-key adv --keyserver keys.gnupg.net --recv-keys [KEY]

после обновления ключей не забывай обновить репозиторий:

apt-get update

equivs: фэйковые пакеты для Debian/Ubuntu

// Февраль 6th, 2017 // 1 Comment » // Debian, linux

Я люблю Debian за его замечательный пакетный менеджер apt, который сам разруливает все зависимости, и для установки софта обычно достаточно одной команды apt-get install <packagename>, но иногда бывает, что именно эта фишка заставляет биться головой об стену, когда пакеты из сторонних репозитариев начинают требовать неразрешимые зависимости, или когда вместе какой-то мелкой консольной утилитой весом в 20кбайт тащится половина Х-ов на 200мегабайт или MTA postfix/exim, там где это вообще не требуется.

Есть замечательная утилита, которая облегчает жизнь в таких ситуациях — equivs. equivs умеет создавать пустые пакеты с полным удовлетворением зависимостей, дабы удовлетворить жажду пакетного менеджера понаставить чего.

И так, допустим, нужно систему заставить думать, что у нас установлен MTA postfix, для начала установим equivs, как всегда это делается легко:

 apt-get install equivs

(далее…)

Mikrotik проверка и переключение маршрута

// Январь 27th, 2017 // No Comments » // mikrotik, Network, routing, script

Ситуация: есть L2 транспорт и его резервный канал, на канале L2 софт использует адрес on-connected (см. рис.) 10.1.1.1, который в случаи обрыва L2 канала становится недоступным и нужно переключить маршрут на резервный канал.

Попытка реализовать стандартными средствами: создать два маршрута на адрес 10.1.1.1, один через основной канал с меньшей метрикой (больший приоритет) и второй с большей метрикой через резервный — не увенчалась успехом, т.к. первый маршрут не становился неактивны при падении линка даже при условии микротиковской фичи проверки наличия ARP. Было так:

/ip route
 add distance=10 dst-address=10.1.1.1/32 gateway=10.4.12.1
 add distance=1 dst-address=10.1.1.1/32 gateway=ether1 check-gateway=arp

но не работало =(

Решение было написать скрипт, который проверяет наличие ARP записи и переключает маршрут
(далее…)

Debian tftpd

// Март 2nd, 2016 // No Comments » // Debian, linux, tftp

Устанавливаем клиент и сервер tftp

apt-get install tftpd tftp

Добавляем в автозагрузку inetd, в файле /etc/inetd.conf редактируем строку, которая начинается с tftp, в принципе она вполне правильная, но мне нравится другой путь для каталога файлов:

tftp     dgram   udp   wait   nobody   /usr/sbin/tcpd    /usr/sbin/in.tftpd   /var/tftp

Перезапускаем inetd:

invoke-rc.d openbsd-inetd restart

Вот в принципе и все. Если что-то не так — проверяем, слушает ли демон порт:

netstat -lnp | grep :69

должен быть ответ похожий на этот:

udp        0      0 0.0.0.0:69              0.0.0.0:*                           15838/inetd

Проверяем/правим права на каталог с файлами:

chown -R nobody /var/tftp

Не удается создать ssh tunnel

// Март 1st, 2016 // No Comments » // linux, ssh

Вот примеры ошибок:

SSH Tunnel: does not support diffie-hellman-group1-sha1 for keyexchange.

и

SSH Tunnel: The negotiation of encryption algorithm is failed

Решение: добавить в конфиг /etc/ssh/sshd_config строки:

KexAlgorithms diffie-hellman-group1-sha1,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1
Ciphers 3des-cbc,blowfish-cbc,aes128-cbc,aes128-ctr,aes256-ctr

сгенерировать дополнительные ключи:

ssh-keygen -A

перезапустить демон sshd

service ssh restart