Archive for mikrotik

Mikrotik проверка и переключение маршрута

// Январь 27th, 2017 // No Comments » // mikrotik, Network, routing, script

Ситуация: есть L2 транспорт и его резервный канал, на канале L2 софт использует адрес on-connected (см. рис.) 10.1.1.1, который в случаи обрыва L2 канала становится недоступным и нужно переключить маршрут на резервный канал.

Попытка реализовать стандартными средствами: создать два маршрута на адрес 10.1.1.1, один через основной канал с меньшей метрикой (больший приоритет) и второй с большей метрикой через резервный — не увенчалась успехом, т.к. первый маршрут не становился неактивны при падении линка даже при условии микротиковской фичи проверки наличия ARP. Было так:

/ip route
 add distance=10 dst-address=10.1.1.1/32 gateway=10.4.12.1
 add distance=1 dst-address=10.1.1.1/32 gateway=ether1 check-gateway=arp

но не работало =(

Решение было написать скрипт, который проверяет наличие ARP записи и переключает маршрут
(далее…)

Изменение MTU на Mikrotik

// Июнь 17th, 2013 // No Comments » // mikrotik, MTU, Network

Как проверить реальное MTU описано здесь.

В консоле добавить запись:

/ip firewall mangle
add action=change-mss chain=forward in-interface=ether2 new-mss=1472 \
    packet-size=1473-65535 passthrough=no protocol=tcp tcp-flags=syn
add action=change-mss chain=forward out-interface=ether2 new-mss=1472 \
    packet-size=1473-65535 passthrough=no protocol=tcp tcp-flags=syn

Не забудьте поменять размер MTU и названия интерфейсов на свои.

Mikrotik отладка скрипта (debug script)

// Январь 12th, 2013 // 1 Comment » // mikrotik, script

Ситуация, написали скрипт, поместили его в /system script, а он не запускается, такое часто случается, когда скприт был написан для другой версии, т.е. отличается синтаксисом.
Быстро проверить можно командой:

/system script print from=<script_name>

которая подсветит неверный синтаксис.