Archive for Февраль, 2017

uTorrent отключаем рекламу

// Февраль 20th, 2017 // No Comments » // Software

Я конечно уважаю труд программистов бесплатного софта и только за, что бы разработчики получали за это денюжку, но когда программа становится похожа на новогоднюю елку и дико тормозит из-за абсолютно ненужных свистелок и перделок, подгрузки рекламы, теряет свой основной функционал и удобство пользования. В общем, в погоне за баблом микроторрент перестал быть микро =(
Есть конечно вариант использовать старые сборки (до 3.2.2), архив >>>, но все же в виду того что новые версии выпускаются не просто так: фиксятся ошибки, расширяется протокол и т.д., поковыряв настройки и интернет была найдена возможность отключить рекламу полностью (бесплатно, без регистрации и смс =).
Открыть меню Options > Preferences > Advanced (Настройки > Настройки программы > Дополнительно), в фильтре последовательно ввести значения ниже и поставить значение false.

gui.show_notorrents_node
gui.show_plus_upsell
offers.content_offer_autoexec
offers.left_rail_offer_enabled
offers.sponsored_torrent_offer_enabled
bt.enable_pulse
utorrent.png

equivs: фэйковые пакеты для Debian/Ubuntu

// Февраль 6th, 2017 // 1 Comment » // Debian, linux

Я люблю Debian за его замечательный пакетный менеджер apt, который сам разруливает все зависимости, и для установки софта обычно достаточно одной команды apt-get install <packagename>, но иногда бывает, что именно эта фишка заставляет биться головой об стену, когда пакеты из сторонних репозитариев начинают требовать неразрешимые зависимости, или когда вместе какой-то мелкой консольной утилитой весом в 20кбайт тащится половина Х-ов на 200мегабайт или MTA postfix/exim, там где это вообще не требуется.

Есть замечательная утилита, которая облегчает жизнь в таких ситуациях — equivs. equivs умеет создавать пустые пакеты с полным удовлетворением зависимостей, дабы удовлетворить жажду пакетного менеджера понаставить чего.

И так, допустим, нужно систему заставить думать, что у нас установлен MTA postfix, для начала установим equivs, как всегда это делается легко:

 apt-get install equivs

(далее…)